ecshop购买商品提示Select_spe未定义的bug

最近有客户的反应说是在使用ecshop购买商品时提示:common.js文件Select_spe未定义的错误,是因为系统缺少js定义,解决掉这个错误也很简单。
打开common.js文件,把如下的代码加入到文件的底部即可。
function remove(id, url)
{
  if (document.getCookie("compareItems") != null)
  {
    var obj = document.getCookie("compareItems").parseJSON();
    delete obj[id];
    var date = new Date();
    date.setTime(date.getTime() + 99999999);
    document.setCookie("compareItems", obj.toJSONString());
  }
}
var compare_no_goods = "{$lang.compare_no_goods}";
var btn_buy = "{$lang.btn_buy}";
var is_cancel = "{$lang.is_cancel}";
var select_spe = "{$lang.select_spe}";  
好了,提示common.js文件Select_spe未定义已经解决了,还有一种情况,就是替换好之后可能会提示缺少语言库,如果有这种提示的话,我们再进行稍微修改一下即可。
var compare_no_goods = "{$lang.compare_no_goods}";
var btn_buy = "{$lang.btn_buy}";
var is_cancel = "{$lang.is_cancel}";
var select_spe = "{$lang.select_spe}";  
把里的lang替换中文。

本文原创地址:https://www.ecshop.cx/article-292.html
版权所有 © 转载时必须以链接形式注明出处!

觉得本文对您有用,想收藏下来!方法很简单:请点击-〉
我们一直坚持白天工作、晚上熬夜更新资源,付出了巨大的精力和时间,其中的辛酸难以言述。

实时购买动态 ×

匿名网友 在 2019-09-20 购买了 ECShop繁体语言预览网站与简体共存使用自由切换